Ticket #291 (closed enhancement: fixed)

Opened 4 years ago

Last modified 4 years ago

make the eventer manage RLIMIT_NOFILE

Reported by: jesus Assigned to: jesus
Priority: major Milestone:
Component: noit-core Severity: annoying
Keywords: Cc:

Description

We use a lot of filedescriptors, make it easy to up the rlimits

Change History

06/06/10 04:42:30 changed by jesus

  • status changed from new to closed.
  • resolution set to fixed.

(In [1332]) fixes #291

06/12/10 00:56:42 changed by jdixon

  • status changed from closed to reopened.
  • resolution deleted.

[1332] breaks the build for Linux.

06/12/10 00:58:04 changed by jdixon

Reverting to [1132] of src/eventer/eventer_impl.c allows the build to complete successfully.

06/12/10 00:59:41 changed by jdixon

The error caused by [1332] in Ubuntu Linux:

make[2]: Entering directory `/home/jdixon/reconnoiter/src/eventer'
- compiling eventer.c
eventer_impl.c: In function ‘eventer_impl_init’:
eventer_impl.c:156: error: ‘uint32_t’ undeclared (first use in this function)
eventer_impl.c:156: error: (Each undeclared identifier is reported only once
eventer_impl.c:156: error: for each function it appears in.)
eventer_impl.c:156: error: expected ‘)’ before ‘rlim’
eventer_impl.c:156: warning: unknown conversion type character ‘}’ in format
make[2]: *** [eventer_impl.o] Error 1
make[2]: Leaving directory `/home/jdixon/reconnoiter/src/eventer'
make[1]: *** [eventer/libeventer.a] Error 2
make[1]: Leaving directory `/home/jdixon/reconnoiter/src'
make: *** [all] Error 2

06/13/10 15:03:39 changed by jesus

  • status changed from reopened to closed.
  • resolution set to fixed.

(In [1334]) fixes #291