Changeset 161

Show
Ignore:
Timestamp:
06/04/10 22:37:16 (4 years ago)
Author:
depesz
Message:

Add Information about requirements

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/omnipitr/doc/install.pod

    r156 r161  
    3333I<lib/> directories (just like it is distributed) - you don't have to set 
    3434I<PERL5LIB> - scripts will automatically find their libs. 
     35 
     36=head2 REQUIREMENTS 
     37 
     38Standard Perl distribution should be enough. On some Linux systems (Debian, 
     39Ubuntu) core Perl modules have been packaged separately - in such case you need 
     40to install also perl-modules package. 
     41 
     42Additionally, you will need some programs installed: 
     43 
     44=over 
     45 
     46=item * nice 
     47 
     48=item * rsync 
     49 
     50=item * tar (it has to be GNU tar) 
     51 
     52=back 
     53 
     54Additionally, you might want to use compression, in which case you need I<gzip>, 
     55I<bzip2> or I<lzma> compression programs. 
     56 
     57Please note that you can use I<pigz> to get faster, but gzip-compatible, 
     58compression. To do so, specify all destinations/sources using I<gzip> prefix, 
     59but add --gzip-path option with value pointing to I<pigz> program. 
    3560 
    3661=head2 SANITY CHECK